Segments and controlling independently

I created a tree (has 115 leds), then created a star with 20 leds and tied them in series.
I cannot for the life of me figure out segments…

If I create a segment 1
there is no option to save it…then when i go to another screen and come back its gone

I created a bunch of presets when I had just the tree and had them loop with preset cycle
I now want to create a set of 3 or 4 effects that would cycle on just the star WHILE the presets for the tree are running in parallel… is this possible?

I cannot find any guide for doing such

I envisioned, select segment, tell wled what to do on that segment, select next segment and tell wled what to do on that segment…
Any help would be appreciated…the fact that a $4 chip can do all this is only possible because someone really smart wrote a LOT of code.

The check button is save.

Thanks for that ! Seems like the box should be empty and when its selected THEN the check symbol should appear.
So I have it checked and can go to another screen and come back and its still there !

Unfortunately the rest of my questions still apply …I have no idea how to setup 2 segments doing something different in parallel…any additional help would really be appreciated !


Can you please tell me, I still do not understand how to make sure that the segments do not disappear? And then he added, configured, and then when switching to other tabs, they all disappear (((And can a preset be applied to the segment?

What is this? It’s an English forum? Looks like spam…

1 Like

I select the desired segment, or several, if you need to configure them the same. Namely, I mark them with a tick, and then set the setting for them.

Ok, i read and reread the section on segments… i deleted all presets I had and somehow created a segment 1 (0-115) (tree) and segment 2 (115-135) (star on top) and then created a few presets with a few assigned only to segment 1 and a few assigned to segment 2. I assigned then IDs above 20 as there seemed to be special rules for 1-16. I selected preset cycle 21-24 and nothing happens …see video clip… What am i doing wrong?..and how does it do them in parallel when ID 21,23 are for segment 2 and the others are for segment 1 ? Thanks again for all the help …but its very confusing to ME (probably not for others) : (

I can’t understand what didn’t work out. One more thing, check inside the segment, there are also settings, so to speak. Make sure the segment itself is on. And create presets for all segments, then they will work simultaneously. And already the very setting of each segment, do it separately first, assigning one or another effect to it. First, work with the setting of the segments, set up each separately as you like, be sure to turn them on so that they all work, and you will see the picture that you like. And then just save it all to a preset. First, make one adjustment by segment and save it to a segment, then another, and save again. But the main thing is not separately, in segments, if you want both the star and the tree to work simultaneously. I turned off segment 0 altogether, did not delete it, but simply turned it off through its settings. And worked with separately created segments.

I wish I could share my screen …anyone use Teamviewer ?
So I’m confused by the statement “create presets for all segments” …can I create a preset that does effect X for segment 1 and effect Y for segment 2 ALL within the same preset ? If so how is that done ?
I did check and the on/off was ON.
Thanks so much for your patience … I’ve been an electrical engineer for 35 years and this has me stumped

FYI, Discord does screen-sharing…

As I understand it, the author wanted to remotely show how to configure. Which, in principle, I did, and in one thing I identified the problem. For some reason, the board does not respond to the on / off button. Accordingly, the settings are not transferred to the device and are not executed. Will try to reflash, and then re-configure.

Many Many Thanks to gekagal for jumping on my system… I was ripping my hair out trying to make it work… He was able to see that the system wasn’t working correctly. specially power control would not work OR more importantly what was showing on peek did not match the LEDs. Well I can say he was SPOT ON… after reloading the nodemcu, I’m able to create sequences like I was hoping. I did download the binary and did a compare and compared exactly…so it seems that something got corrupted. Is it bad to use both the PC and the iphone app …can that cause issues ? or the fact that I started with 115 LEDs and added 20 ? Anyway thanks to gekagal and everyone else for the advice… Using teamviewer was the only thing i knew…if discourse would do the same thing that would be great …we had trouble with audio on teamviewer for some reason…does discourse allow audio talk while screen sharing and does discourse allow me to give control to someone ?
thanks again!

1 Like

So i created 9 presets with the star and tree having different effects. When I got to the 10th it started to act incorrectly…for example… I turned off segment 2 but it still is lit up (see pic) … what is the limit of what I can do…my esp8266 had 4M. How do I tell if I’m running out of memory…will attach info…


I had problems with sound, I already decided. You reflashed it again, but the problem persists? I use both settings from a PC and through an android application, everything is fine, I don’t know how from an iPhone. And the fact that you created segments with a different number, I think, should not affect this in any way. But the fact that I don’t know English is bad. But if there is sound when contacting, then it will be possible to use Google translator through a microphone)

Well, after reflashing things worked fantastic…UNTIL i created 9 presets …after that it did not work quite right…trying to determine whether I’m overloading the system or can i make 100 presets ?

also after reboot …it forgot the segments…is that correct

I have 115 presets, and everything works, the memory on the board is also 4 MB. But why the segments disappear is not clear. Perhaps you did not save them, what I did periodically when I was on your system.

Judging by the fact that you no longer write, everything works?

Well I just tried it again…and it not working correctly… trying to define another preset …I turn off segment 2 but its still running as you can see in the picture… the power (top left) works correctly… any ideas

sorry I figured out if I looked at segment 0 and turned off…things are back to normal and I have been able to create more presets …thanks for help and Happy New Year