Sync issues with latest V13 B7 Release

I have 5 8266 cards controlling my home bullet WS8211 DMX lights. One of the 8266 cards is just used as a control point to save presets and sync to the other 4 cards. It was all working fine with V13 B6. After updating to 13 B7 the ability to sync was lost. When I changed the presets on my master 8266 controller it had no effect on the other 4 8266 cards that are actually controlling the lights. I have gone back to V13 B6 and everything is working again. Seems like a major bug for my configuration at least. Thanks for your help.

You will need to post some more information for it to be considered a bug.
Sync has seen a deep modifications and may need re-checking your set-up configuration.
Please post some screenshots of your Sync settings page.

This is the sync settings on all 5 of the controllers currently using V13b6 because it still works. Nothing is changed from the default settings from the original WLED install on these controllers because sync all worked from the very beginning. As soon as I update to V13b7 sync is broken.

I would expect you post b7 settings. Not the ones that work…

My point is I am using the defaults, nothing is changed. I would expect to be able to install the update and it should workl? Here are the settings after installing V13b7. Perhaps segment options and bounds also need to be checked now? Thanks

Please select/check segment options but leave bound unchecked and report back.
You may need to have all units updated.
Meanwhile I’ll have a look into the code.

I don’t see any flaws at a first glance but old code received a major rewrite by @Aircoookie while porting full segment syncing.
Will need a bit of debugging.

One more question: Did you have b7 only on sync master or on all devices?

All devices. Thanks

Do you have multiple segments on the sync master? Non-segment sync (which is still the default) should always sync the main segment (which is segment 0 unless changed by API).

Does the sync stop working completely or does changing the master brightness or using the on/off toggle still sync correctly?

I do not have multiple segments on the sync master or any of the other cards, just what comes as default. The changing of master brightness and using the on/off does work. I upgraded to V13.1 and had the same issue. So I tried checking of the segment options. That fixed the problem on 2 of the 8266 cards, they are synced and working. I had 2 other 8266 cards that the Sync Interfaces option web page no longer works so I backed them to V13b6 and those two now work. The Sync Interfaces option web pages will not open to set sync options on those two cards with V13b6 no matter what I do. Any ideas how I can make that page work again on those 2 cards with out going on my roof and pulling the cards and re-flashing/re-configuring them? I am not sure at what point the pages stopped working on those pages over the last few months of testing beta versions.

Are the sync settings pages of those just white screen? If so, please share the output of Ctrl + U on that page. It might be that the length of settings exceeds the available buffer size (which will be fixed soon!)

Using a windows 10 PC on the same network, the web page for settings after trying with the spinning icon on the tab for about a minute it goes to white page “Hmmm… can’t reach this page”. Ctl + U just opens another tab and repeats the process to another white page that says the same. All other settings pages work fine.