Timer light and preset who to?

Hi, i would like to shutdown my leds after 10 minutes ( for example ) after i apply the power.
Not at a specific time but after a couple of minutes …
I found how to shutdown at a specific time with NTP server and Time-controlled presets
I tried to make 2 presets on with only T=0 but i cant make it work .
Can someone help me ?
Thank’s in advance

Create a playlist that ends with a preset that turns off your strip.

Nice trick , I set an effect for 10 min and then a shutdown preset and added then to a playlist . I think it is working .

Just a question since you seem brainy and I am not yet that familiar with WELD.

Can you directly adjust the timer function in the main interface to shutdown the LED after specific time other then the 60 Minutes . Or is this a fixed time ?

There are so many options most of which in very small fonts that really too complicated due to the flexibility with WLED . i am a bit lost

Make sure you’re running a current version (0.13.0-b6) and check out LED Preferences → Timed Light.

Keep exploring and look at the current documentation: https://kno.wled.ge
You’ll find many examples by searching the forum as well.

I’m running 0.13b version and i found Timed Light in Led Preferences but it doesn’t work if i donot toggle the button Timer in the main page of the WLED interface with my phone ?!
How can i save or activate this Timer to make Timed light working ?

Nice trick, thanks
Maybe you can explane me why Timed light function is not working ?!
( i’m using 0.13b version )

It works when you activated the “Timer” button from the main GUI (beside the Power button)

I know but my question is how to make it active in preset so i don’t need my phone to activate Timer ?

Read my previous response about using a playlist (which is a set of presets).
You can set the run time for a preset down to a minute.

You create 2 presets, 1st with strip on the way you want ON and 2nd with the strip OFF.
Set both in a playlist specifying the time length for each.
Use the playlist # as the item for your Timed Macro.

Yes as i said before nice trick . It works i tried just after your message, but i wanted to know why the state of the button Timer in main page is not saved with preset ? or is there something i’m doing wrong ???
Thank again for your solution

Never looked at that one before, might be a bug…

You can make it work if you start to learn about the JSON API ( see: JSON API - WLED Project )

That gives you control over everything.
Build a preset with colours/brightness/etc. the way you want and save it with “Overwrite state” checked.
Go back in to the preset, uncheck “Overwrite with State” and refresh the browser page.
The box will fill with the current JSON string representing the preset.
You can edit that and add:


before the first segment definition.
That will add a 23 minute fade to your preset.
Be very careful how you add JSON strings, they’re very picky and do NOT like extra embedded white spaces.

It would be well worth your time to research the JSON (and other) API sections.
They are very powerful…

Many thanks for your help, its really powerfull all the thing you can do with preset, api …
Merci beaucoup .