Total LEDs isn't working

Hello, first post here. I’m having a problem getting all the led’s on a 40 LED strip (144 LEDs per meter). I’m using an Athom controller with WLED pre-installed. Ok, here’s what is happening.

When I first turn on the controller, all 40 LEDs light up orange, just like it’s supposed to. However, when I select an effect in the WLED app, only 30 LEDs lite up, even though I have entered 40 in the LENGTH field under the Hardware section (START=0, LENGTH=40) and saved it( Total LEDS confirms this as 40 is in the field.

For the life of me I can’t figure out how to fix this. Thing is, I have a bunch of various length and quantity of LEDs per meter, strips that I need to test before installing them so I need to solve this as soon as possible. Thing is, this strip is only one of 4 strips going into various locations in a custom built computer, that will be wired in series so they act as one continuous strip, but as of now, since the effect signal doesn’t get to the last led, that will prevent the rest of the strips from getting the signal as well…at least I think so.

Also, I have nine, 12" strips of 144 leds per meter, that I want to display the same effect simultaneously. Can I wire up all nine strips in parallel to the controller?

Any help would be greatly appreciated.


SUCCESS! OK Guys, I figured it out! This is the first time I’ve used the WLED app, so I knew very little about it. So I started looking at everything and trying different things to see what they do. I Had already tried the effects and even made a preset, but hadn’t tried the segments section yet. LO and behold, when I selected the only segment displayed, a bunch of configuration fields came up. For this segment, it showed one “group” and zero “spacing”, and in the led " quantity it showed “30”…it dawned on me! So I punched in “40” AND HIT APPLY…VOILA! IT WORKED! Ok, now I know enough to test these strips
out I finally can finish up my custom computer, which is pretty cool itself. I built it as a rack mount that fits in one of the sections of my workbench upper cabinet. This computer is for CAD/CAM apps for my CNC and 3D printer. It’s taken me a year to build it as I have loaded it with all kinds of aluminum extrusions, translucent colored and clear plex diffusers, cool hardware, and white, RGB and Assignable RGB led strips.
Also, I built 9 vertical “light bars” out of aluminum extrusions that house a 1/4" clear plex diffuser that mount along the front edge of the upper cabinet vertical dividers. These are actually diffusers for the 9 led strips I mentioned about in my last post. Also built a horizontal lightbar that mounts on the top front edge of the upper cabinet, full length. This diffuser will use a Superbright SILICONE diffuser in front of a 5.5 meter, 60 leds per meter strip. Now that I’ve got this wled thing working right, can’t wait to finish up all of these projects. Just started designing a new one too. My man cave workbench is going to become a space flight simulation cock pit for a game called ELITE DANGEROUS.

Ok guys, I have a bunch of questions, but I’ll get to those later.

Hi guys. I’ve got a few more questions. First off, I don’t understand a lot about the wled app so I get myself backed into a corner. This morning I was testing a 144 led per meter strip and after fooling around in LED preferences and segments I finally got the whole strip working. Unfortunately,somehow I found myself on the wled page where you can add new lights. Only this one was different, as a message was displayed saying “CLICK ON LIGHT TO HIDE”. I had tried to get 3 different NEW LIGHTS working to no avail. Then i tried to get the fourth one working. I custom named it WLED4.3.2,1 and to my surprise it worked, the strip
lit up bright orange. However, on that “HIDE LIGHTS” page, I tried to get out of that page but accidentally tapped on the WLED4.3.2.1 LIGHT and hid it. Does any one know how to UNHIDE it?

I tried adding a couple more lights, but I failed to get them working. As I added each light, I gave it a custom name and when it appeared in the list of lights, there was also an IP address. I have no idea where this IPaddy came from or what it’s for. However, I clicked on one of the new lights and a wled page appeared with a “LOADING” prompt. I don’t even know what is being loaded. However, after about 5 minutes another message popped up saying “DEVICE UNREACHABLE” WEB PAGE NOT AVAILABLE"

I don’t understand this whole ADD NEW LIGHT process… AMONGST A WHOLE LOT OF STUFF I DON’T UNDERSTAND. For example:

  1. Under each light name there is a dot that you can pull across the screen, and a symbol on the far right. What do these do?

  2. If there some specific IP addy that needs to be listed under each light, and if so, what is it and how and where do you enter the IP ADDRESS info?

  3. Is there a web page that explains every thin about the wled app? I’ve watched tons of youtubes and have read tons of info but for some reason I can’t find a complete tutorial on the wled app.

  4. When I click on the wled icon on my phone, normally, the wled page appears with the color wheel, but sometimes it go’s to a different page. How do I get to the color wheel page from a different page? Ok guys, nuf for now. Any help will be greatly appreciated.

Hello [blazoncek, thanks for the link. I read everything but still didn’t find the answers to my questions. I am currently raking the internet for answers. Thanks again.

you don’t set the top total, but total for each pin :wink:

Hello tonyno. I’m sorry but I don’t understand what you mean by “pin”. The controller I’m using, which is an Athom, doesn;t have any “pins”. The three wires from the led strip simply fit into holes in the controller and are fastened with small screws. BTW, I’ve already figured out how to enter the number of leds in the LED preferences and segments. My main problem is entering a correct IP address when creating a “NEW LIGHT”. I don’t understand where you get this IP address from. When I try to create a New Light, an IP addy is already in the field where you enter one, which I have no idea where it came from. And when I assign a custom name and then clik on it. a page pops up saying “LOADING”, which I don’t have a clue WHAT is supposed to be LOADING. However, after about 5 minuites another page pops up with a message that says “WEB PAGE NOT AVAILABLE”! I’ve searched the internet for a week but can’t find any info on where to get this IP address that is correct.

Also, I accidentally “HID” the only NEW LIGHT that was working. I managed to get this light working somehow by entering an IP addy that I tried, which I don’t remember, but now I can’t figure out how to “UNHIDE” it. If I knew these two things, I’d be able to move on. If anyone can help me solve the IP addy and the UN-HIDE light issue I’d be forever grateful.

Hey guys…SUCCESS! I figured it out! WLED absolutely is amazing!

OK, I took a guess, right or wrong and entered in the IP address on the NEW LIGHT page.
, set a custom name and selected it…VOILA! The app came up and the strip started lighting up with an effect…except it only lit up 30 leds. Took 2 hours to figure out you have to set the number of leds for EVERY preset in the SEGMENTS section…at least I think so, no matter it worked My test strip is 1 meter of 144 leds per meter, which I will cut and solder connectors for 5 various length led strips in series that I am installing in my custom rack mounted computer, . I’ll post more pics when I can.

Meanwhile I still have a lot questions but more on that later. HAVE A GOOD NIGHT and thanks for any info.

1 Like

Hello again. I’ve come across a problem that I can’t seem to figure out a solution. Here;s my delima. How do you control 2 or more seperate controllers with the WLED app? Let me explain what is happening.

I’ve got two WS2812b LED strips, each of which are connected to a seperate ATHOM controller with WLED preinstalled . I also have the WLED app installed on my smartphone. OK,when I first hooked up the first strip to one of the Athom controllers, my phone detected a wifi signal called wled0000. I managed to get it to connect and the led’s came on with an orange color, which I found out is normal. Also’ the wled welcome page popped up on my phone. At this point you have two options, (1) go to the wifi setup page or (2), go directly to the controls. I opted for go directly to the controls as I know virtually NOTHING about wifi.

OK, I’m not exactly sure when it happened but at some point a “NEW LIGHT” page popped up. I didn’t understand what I was supposed to do and still don’t, but after a week of research, and trying every thing I could, I finally managed to get a new light to work by inserting the name wled. …which was just a wild guess. Anyway it worked as after I selected it, voila, the controls page came up to my surprise. I spent the next month experimenting with the effects, sections and presets. After setting up some presets etc, I decided to hook up the second led strip to the second Athom controller.

After hooking up every thing, I plugged the power supply in, and waited for a the wifi signal to be detected on my phone. Sure enough, after a few seconds, the wled_00000 signal popped up. But after a few more seconds another wifi network signal popped up, only it had a different name…wled31574 …or something to that effect. OK, after getting it connected, just like before, the wled welcome page popped up. NOW, I’m not sure what happened next, or how I got there but just like before, the wled "NEW LIGHT "PAGE popped up. I really didn’t know what to name a new light, but i must have named, it something correct cause voila!..after selectng it the controls page came up to my surprise…again.

After spending a couple of hours getting some presets setup it was time to get the FIRST strip working again. I’m not sure why, but after looking at the wifi network settings page on my phone, it appears only ONE network can be connected, which meant in order to get the first strip working I had to get the wled_00000 network connected,which I did and went to the wled controls page for the first led strip and selected a preset which is a different preset than the preset for the second strip, VOILA! both strips were working exactly how I wanted. But now i wanted to change the preset on the second strip, which meant I would have to go to the wifi network settings page on my phone… AGAIN. OK, I go to the wifi network settings page on my phone…but something has happened. The wled network wled_31574…IS NO LONGER THERE…but the wled_00000 network is still connected.

OK guys, this is where things got really wierd. At this point, I decided to go to the wled app preset page to see if there was anything that might allow me to switch from the preset page for the first strip to the second strip. GAK! When I get to the presets page…IT’S THE PRESETS FOR THE SECOND STRIP!!!..EVEN THOUGH THE WIFI NETWORK IS FOR THE FIRST STRIP/CONTROLLER!!! Moreover, now I can’t find any way to get to the presets page for the first strip!

OK guys…I’m totally baffled after spending hours trying to figure this out. Thing is…eventually I’ll have a dozen or more led strips outside and inside the house and shop, with different brands of controllers all controlled by the wled app. I’m sure there must be a simple way to do this but I can’t find it. Any help would be greatly appreciated.