Unable to access WLED AP from other PC or phone

I used my desktop (Win 10 Asus) to set up WLED 10 on my Lolin Nodemcu v3 as an AP (not on the network). When I click on the WLED AP, it automatically opens in After configuration I disconnect the desktop from the nodemcu and then attach it to my outside ws2812 string.
Then I take my laptop (Win 10 Lenovo) outside to view the leds at different configurations.

However, the laptop sees the WLED AP and when I try to logon with the wled1234 password, it says incorrect password. I also tried http://wled-ca53af.local as given in the WEBUI but it does not work nor does The same thing happens when both PCs are in the same room. I did disconnect and repower the nodemcu between different connection attempts.

An iPhone also cannot connect to the WLED AP.

Is the nodemcu attached only to the desktop even when disconnected and not available to the laptop? What am I missing?

laptop wireless ac driver is up-to-date.

First, when you flash your NodeMCU after reboot you will see AP. You have to connect to AP and configure access to your Wi-Fi network. After reboot your NodeMCU will connect to your network with new IP address. Then you can run App on your phone to search and add your controller.
Here is nice tutorial https://tynick.com/blog/11-03-2019/getting-started-with-wled-on-esp8266/

At this point due to other issues with my wifi network, I am only trying to access the AP in AP mode rather than network. I think what you said is correct, but does not apply to an AP only which is allowed for WLED per options in the webui.

In this case you can access interface only if you connected to WLED-AP and then you can use address It should be no difference from what device you connecting.

I would have agreed with you until I had this experience. The desktop connects to the AP but the laptop does not. The laptop performs all other network connections just fine, but not this one.

Something strange is going on. Did you try to attach board to laptop and reflash it? Which binary are using?

I did not try to reflash the bin (WLED_0.10.0_ESP8266) because it was working just fine on the desktop.

Here is some additional information.

My Lolin nodemcu V3 flashed with [WLED_0.10.0_ESP8266.bin] did connect with my home network on ASUS RT-AC3200 using my home Win 10 PC. However it will not connect at my summer home on a new Arris SBG10 modem/router on a Spectrum internet. Using a different Win 10 PC, I can access the WLED AP, but when I set the ssid/password for the Arris 2.4 GHz band, it fails to connect. The Arris DHCP is enabled. I have even tried to manually assign an IP address in the WLED AP, but that does not work either.
Meanwhile neither my Win 10 laptop nor my iPhone can connect to the WLED AP using the default password wled4321.
I contacted Arris technical support to report this problem. Their response: “What is a nodemcu?” Then I was elevated to a higher support level and they suggested that I contact the nodemcu manufacturer and ask them for assistance. I can imagine what a waste of time that would be.
Any more ideas?


Maybe try a different esp8266 device. Also the password I believe is wled1234 NOT wled4321 as you stated ( I could be wrong) I can connect in AP mode with Any device… phone, laptop, desktop basically any wifi enabled device. I have even connected 2 different phones at the same time and both can control the lights at the same time. The issue you have described does not sound like an issue with the Wled software to me. IMHO

@klrock Do the LEDs light up orange if you connect them to the ESP? There could be an issue that prevents it from powering up if the LEDs are pulling the GPIO2 pin low.
It might also be that your specific NodeMCU is damaged somehow, which sometimes happens.
If you have a different board to hand it would be cool to test that, because while some people have experienced issues with connecting to their home network, AP mode works almost always…

The Arris support site recommends: Disable Band Steering (among other things which you already tried).

Band steering was not enabled.

The LEDs light up orange when the nodemcu is powered.

Flashed an identical nodemcu and got exact same behavior.

Have several of these nodemcus. Tried another one and had same issues.

If you power up a nodemcu with wled 0.10.1 firmware installed - but no LEDs connected to power supply or data port, does the nodemcu then connect to the problem laptop and/or arris router/dhcp server?

How far away is the NodeMCU? Is it in a case? Are there lots of neighbors very nearby who might be competing for 2.4GHz channel bandwidth, causing the nodemcu to have a tough time finding the router and making a connection?

If the NodeMCU is outside any case and right next to the router with no LEDs connected, does it make a connection with the router (you know, the perfect situation)?

How is the NodeMCU getting power when it is connected to the LEDs? Hopefully not via USB.

1-I don’t have 10.1, but I reflashed 10.0, thinking the password may have been corrupted. With no leds connected and not using my desktop at all, both the laptop and the iPhone responded incorrect password for wled4321 for the WLED AP.,

2-About 15 feet with no barrier between. Very few neighbors on 2.4 GHz during test. During operation on the desktop, the nodemcu is in a plastic case and located about 30 feet from the router with an aluminum motor home wall between and works perfectly.
Some how I am getting the WLED error message, but my nodemcu has 4 MB flash memory.

3-No case during this test and no connection in perfect case.

4-Power from 5v supply goes to leds and then to Vin/Gnd.

Please double check this again. The passwort is wled1234 (not 4321), make sure that’s what you entered!

OH MY GOSH! I had written it down wrong. My bad. My apologies to all who have helped. Now all PCs connect to the WLED AP. However, I cannot get it to log on to the network. The Arris router has DHCP enabled, but no IP gets assigned to the nodemcu.

I also get the WLED error 2 message even though nodemcu has 4 MB (32 Mb) flash memory*.*