Unstable WiFi connection

Hi.

this is my first time using WLED, I already have around 20 tasmota devices running without any issues.

I have a Wemos D1 mini flashed with latest beta build 0.14.0-b1, Signal Strength is 100% (-46dbm). I have random connection issues. When I open the WLED Webserver I have sometimes messages that WLED is not reachable. I set up a Uptime Kuma Monitor to ping the device every 20 seconds:

I already flashed WLED twice with erasing but problem remains, I also flashed tasmota on it and that worked as expected and commands were applied instantly.

I have a 5m 300 LED strip attached together with a 100W power supply with 2 joints at start and ending of the strip, Power measurement turned out that a maximum of under 80W is used so there is enough power for the D1 available. The D1 get its power from the power supply directly.

I couldnt find a serial output, console or Log Output at all so I really dont know how to debug this problem. Any hints or recommendations how I can solve this ?

If the Wemos D1 has a USB port, that will give you a serial port to monitor while the board is running.
You may or may not have to disconnect 5V power from your main supply to avoid a USB power conflict.
If you do run off USB power, make sure to keep a ground connection from the Wemos to the strip as well as data.

You should be able to see status messages on the serial port and see if you’re getting a brownout or some other indication. Worst case you might have to load a Debug compiled version of WLED to get more info.

Are you using HomeAssistant?

Yes WLED is integrated into HA via Integration, but controlled via node-red. Couldnt find out how to get Log output from USB connection, as a first step I downgraded to 0.13 and give it a try.

HA can assault wled with too many requests. For testing, disable HA to see if it still happens.