Which Controller is this and could I flash Soundreactive?

Hello,

I’ve bought this Controller with 20m LED’s (30 LED/m).

My Main Problem is that I don’t know if it is strong enough for Soundreactive WLED because I couldn’t see if it is SP511E or SP501E. It has an ESP8285 on it and SP511E has ES8285 too.

Here are Pics of the ESP8285:

Sorry, because I’m new I could only Post 1 Mediafile :frowning:

I hope you can light me up :slight_smile:

Thx forward.

It would be easier to identify if you showed the case instead. Both have the same ESP8285 chip. Early SP501Es came with 1mb instead of two. Does it have a mic, IR?

Yes, it has an Mic. No IR, as far as I can see.

On the Case is nothing more to see than the Infos about Voltage.

After some searching I found out that it has 2MB because it’s an ESP8285 H16 :wink:

Now I’ve connected everything but I couldn’t flash it :frowning:

Flasher → Module
GND → GND
GND → 100
3,3V → 3,3V
TX → RX
RX → TX

I get no connection for flashing. What could I have done wrong?

I thought this would be the same way as an SP511E which I’ve flashed successfully :slight_smile:

You could try and disconnect the Io0 to ground and watch with a serial monitor during power up.
You should get some status messages.
That might tell you if you’ve got Tx & Rx in the correct order and the correct pins.

Have you got a picture of the other side of the board and the casing?

1 Like

Sorry, just noticed the other pics.
Did you have a case pic, seeing the style of that box “out of the package” might twig someone.

My comments on Tx/Rx still stand sometimes what you “think” Tx should mean is reversed.
It might be worth tracing the GPIO1 and GPIO3 pins (should be Tx and Rx) to make sure there isn’t anything else on there. Might check GPIO0, in case there’s circuitry that does it’s own power weirdness.

Happy New Year :slight_smile:

THx for help :slight_smile:

Here is an Pic of the Case:

I measured the pins and RX is RX on the backside, TX is TX on the backside and GPIO0 is Io0.

I don’t understand why I can’t flash. Everytime I use NodeMCU PyFlasher says to me that there is no Connection :frowning:

I’ve connected Io0 with GND, then I connected all others with my FTDI as written above.

Yah looks OK for pinout.

I wonder if the FTDI isn’t able to supply enough current to run the attached circuitry and the ESP8285 at the same time? There’s much talk about using a CH340 due to increased supply capability.

You could try disconnecting the V33 Line from the FTDI, leave everything else connected and power from an external 5V supply. Might be tricky getting the timing right for programming but worth a try.

Still be nice to know if you get power up messages on a serial monitor when you’re hooked up without IO0 grounded as well. Will prove the wiring at minimum.

Just had another thought - I see in your top side board photo with the Tx/Rx markups there’s a glimpse of what looks like a 26MHz oscillator. I wonder if they’re running the chip at some weird baud rates?

Even more interested to see what the power up messages on serial look like. If you play with the baud rate on the serial monitor, it may give you a clue as to what they’ve done.

I’ve tried to get information at bootup from Serial Monitor. Therefor I’ve started Adruino IDE and the Serial Monitor.

First I’ve tried with 3,3V of FTDI (CH340) with several Baudrate, but nothing to see :frowning:

Then I’ve disconnected the 3,3V and powered up with an 5V power supply. Same behaviour.
Then with an 12V power supply which was delivered with that Controller.

There is nothing to see in Serial Monitor.

Is there an other Serial Monitor which is better?

The Arduino Serial Monitor should be fine.
I’ve used that, Hyperterminal, Putty, TermText, etc, etc,etc. they all work ok.

When you hook up for monitoring, you need to disconnect the IO0 to Gnd as that locks the board into Flash.
Other than that, try swapping the Tx/Rx pins (although they should be right from your descriptions).

@divsys
Thx for your help :slight_smile:

IO0 was disconnected from GND. I also tried swapping RX/TX. Nothing worked.

I’ve downloaded Free Serial Port Monitor, also nothing to see.

I get an SP511E from Ali and flashed it without any problems, so why this thing isn’t so easy to flash???

Definitely something to make you go Hmmmmmm :thinking:
Did/does this thing actually work at all?
Any way to verify the original operation?

Maybe someone can jump in with some thoughts

Yes, it works normaly with Original Firmware.

I wonder if it’s worth trying to connect up an explicit Reset button to force a reset after power up?
And/or change the IO0 short to Gnd to a button as well so you can try different versions/timing of Reset and Flash?

I will try the next few days, when I have more time :slight_smile: