WLED WebUI losing connection, "TypeError" warnings

Hi All.
New to the WLED game. I have successfully flashed a binary ( WLED_0.10.0_ESP8266_1M_full.bin ) on to a LifeSmart Cololight, the original non-pro model. These are based on ESP8266 with 1M flash.
I have connected & set up the device, and all works ok initially, but I seem to keep on eventually running into connection issues. I get warnings in the WebUI of “typeerror failed to fetch” or sometimes “typeerror cannot read property of null”. Sometimes I cannot load the WebUI at all, the request will timeout. I can still see the unit connected to my router tho when this happens.
I should note I have already tried some steps such as disabling mqtt, blynk, alexa, etc.
Is this just to be expected with the limitations of the board? I see some are being deprecated in the upcoming release making this now the minimum spec hardware…
Or should I be able to get this running stable?
Just trying to get an idea if I should sink more time into troubleshooting or not…

Sometimes I get “connection to light failed. Please refresh the page. If the issue persists, reboot your ESP.” but this usually disappears and is replaced by TypeErrors again without a refresh.

How far away is the ESP module from your router? The basic pcb antenna’s found on ESP8266’s often have very limited range and can cause communication errors. Set up a test rig with all components within close proximity and see if you still get the problem.

Hey Modelman. Thanks for the response.
The module isn’t far from the router tho, only around 6ft. I was using this unit with its original commercial firmware before flashing WLED and never experienced connection issues then. I’ll try it right next to the router and see.

There are various settings which seem to help. Disable sleep mode (prevent wifi for taking a nap).
If you have any full-time online PC or PI or server in your home where you can schedule periodic pings to the light, try scheduling a ping every minute. For proof of concept, just use ping from console/command line/terminal with 30 seconds between pings and let it ping forever (or until you tell it to stop). See if that affects the light staying online.

Search in this discourse group for wifi dropped and see if you find a similar situation where someone solved it.

I would also recommend giving the WLED_0.10.2_ESP01_1M_full_fix2009030.bin binary from the 0.10.2 release a try. It uses less heap memory and should be a bit more stable than 0.10.0.

Thanks for the suggestions all.
I’m now on the latest binary but I’m afraid I’m still not having great luck keeping a stable connection. I have sleep mode disabled.
Pinging every 30 seconds seems to make little difference, when I lose the webui the ping requests timeout(occasionally alternating with ‘host is down’).
I’ve had some success controlling the light via HomeAssistant with the integration even after the webui becomes unresponsive. But eventually the HA integration will lose communication with the light too. I did not have the HA integration running for most of my testing with the webui, it’s just something I tried at one point.
I do know with the original firmware on this light, it did not do status reporting & communication was only one way, but it was pretty reliably responsive. Maybe it’s just not cut out for WLED.

Have you tried a static IP?

Yeah I’ve been using a static IP the whole time…
I decided to try reflashing again. This time I had a whole lot of trouble even getting the AP to show up or connecting to it once it did.
So I went back a few releases and tried WLED_0.8.5_ESP01_1m.bin.
First impression is the webui is lightning fast with only a slight lag in commands sent to the light.
It’s early days to know if it’s stable but it’s looking very good. I’ve already got it talking to Home Assistant and Hyperion and seamlessly switching controlling from all three.
I mean, I’d love to have the latest & all the new features, or just to troubleshoot the why of it… But for now I’m delighted to have an older release that does most of what I could want.

Checking back in to say 0.8.5 has been running great for me, so much so I’ve flashed it to the remainder of my devices.

I do have 1 newer model that is based on an ESP32, and I was wondering if I could flash this with the latest firmware and have it send sync data to the older models? Would that work at all or would I run into trouble mixing and matching firmwares like that?
I’m guessing I’d need something that would send out udp real time rather than the wled broadcast which appears to just relay commands?