WRGB question with Wally's Floods

Hi All,

Just picked up 3 of Wally’s 30W WRGB Floods, and I cannot get them to light up the blue LEDS. I’m using WLED Release 0.13.3, have selected SK6812 and tried every combination of color order. I can get all of the other colors to match using the BRG sequence, but I cannot get Blue (and any colours that need blue). I just the white light on instead.

Any suggestions? From what I’ve read, WLED is supposed to work with WRGB lights, but I’m definitely stumped.

Those floods are using WS2814 protocol LEDs, a subtle variant of SK6812.
There’s a known issue with those where the White and Blue channel are swapped in the data stream.
You can read about the details: here

There’s a fix available in version 0_14 currently under development.
You can build one yourself or there’s a pre-built version in Serg’s files that should work, try :Serg-V0.14 build ESP32

Thanks for the quick reply. I saw that posting, but my interpretation was that if the W and B channels were “swapped” that would mean that blue would still show up if iI tried selecting white, but I guess that’s not the case.

I tried downloading the version 0.14 file but I need the ESP8266 version and I’m not skilled enough to figure out how to build that one so I guess I’ll wait for the official version to come out (hopefully soon).

Try the ESP8266 version.

You Rock! That worked.

In case anyone else is interested, these are the settings that have the new Wally’s WRGB Floods showing the correct colors.

SK6812 RGBW
Color order: BRG
Swap: W & G

Thanks for your help!

You might triple verify that you’ve got the exact colour sequence right.

Display each of R, G, B and W as the only colour shown.
I mention it as the previous instances have all complained about B swap.
If the RGB/BRG/GRB sequence is wrong, that will change which colour needs to be swapped for W but some other colours will come out wrong.

I’m not saying you’re incorrect, just be interesting to know they have a “different” variation of their lights and/or the WS2814 protocol.

Glad you’re up and running.

Color sequence appears correct. Each single color that I choose in WLED is displayed correctly in on the floods. That part seem to work ok.

However, I cannot get xLights to work correctly with the Floods. I’ve set them up as 4 channel WRGB, and tried both WS2811 and TM18XX as the protocol - no luck. There is some syncing but the colours are “random” and for some colors the lights are off. Very strange…

I would try the xlights zoom room. I hear they are very helpful.

I seem to recall seeing something about Xlights possibly dealing with W channel swap in code on top of the WLED swap for TM1814?
Is there a setting for straight SK6812 RGBW in Xlights?

Unfortunately I’m not an Xlights user, just relaying what’s passed by.

So interesting - had to leave my setup for a couple of days. I now can’t get the “swap” to “stick”. I can click whichever swap from the dropdown, but once the WLED resets the swap goes back to “none”. Thoughts? I tried reloading release 0.14, not luck.

What are you seeing for FS and heap size on your install?

I just ran into a few 8285 installs that wouldn’t load via the OTA or install.wled.me web tool.
Had to go back to serial and the esptool util to do a full wipe and load.

I was seeing very wierd FS numbers like 10345769kB (!!!).
After a full wipe, it seemed to reload via serial ok, but I’m still seeing a pretty small heap size (17.6 kB).
So far it does seem to run OK, although I’m not pushing it very hard either.

These are just guesses on my part, I haven’t run into not being able to save my configs.