Wrong color with E1.31 multi universe

I have chained 7 strings with 50 leds each for a total of 350 leds. When I use WLED app I have the right colors with GBR as color order.
But when I use Xlights with 3 universes of 510 channels each configured as GBR type, with solid effect color red, only the first universe has the correct color (red) the other 2 universes have blue color.
What is wrong?

How many wled controllers do you have? The correct answer for your specific situation is 3.

Change the colour order to RGB in xlights (for each model) as WLED sorts the colour out (as it’s set to GRB in there). I did the same at first and this sorted it.

I’ve only one controller. In the WLED wiki I read:

  • 170 LEDs (510 DMX channels) are supported per universe.
  • You can use up to 9 adjacent universes which is a total of more than the maximum 1500 LEDs WLED can drive .
    I think that one WLED controller can drive 350 leds, isn’t it?

I’ve tried but I still have the same problem.

No. Mine drives 577 LED’s with no issue

Can you post some screen shots of your model layouts from xlights?

These are some screenshots of my configuration

My apologies. I misread your post as 510 LEDs x 3. Have you sorted it out with help from @demonzen2001 ?

No, I tried the configuration suggested by @demonzen2001 but with no success.

I am running many leds on wled no issues. Thinking you configured xlights incorrect.

I would create a new show directory. Add the controller then add one string 350 leds don’t change any color settings. Try it. That’s all I do and everything works like a champ.

Think you might have an old version of xlights also based on screen captures.

I have updated xlights version, then I select a new show directory and configure a new controller (e1.31 with universe count = 3 and start universe = 1), then add a single line with 350 nodes/string.
Unfortunally I’ve always the same behavior : the first universe has the wrong color (green instead of red) and the remaining leds (universes 2 and 3) have the right color (red)

Does wled have segments defined?

Also is it possible to swap your strings around or connect to pixel 171 or higher see if you have the same issue?

No I have only one segment (the default for all 350 leds).

At the moment it is not possible to swap strings or modify the wired connection.
However the strings are ok with Wled native effects, colors and palette.

I am at a loss. Only suggestion I have is reset and test with a bench top setup. That’s all I know to Do in these types of Situation.

If I were in your shoes I would flash a new wled controller. Tie 50 lights to it. Verify if xlights functions, if it does add more lights. If it does not then need to start the debug depending on the issue.

I certainly can’t explain the problem. I do know one thing gremlins are real and I had them move in last Saturday. They are now gone, but that day they caused some crazy things that appeared unexplainable. All of the gremlins were killed though by add power. Seems to be my most recent fix for all my issues. The only one I have not fixed is my mini arches. I have half a strip that is the wrong color. When I pick blue it will go red on the last half. I am going to see if adding power will fix but it is so strange it works just wrong color. Your situation is the opposite and at the beginning.

You could also try turning one pixel on a t a time. In xlights just to see what happens.

I have these results:
led 1 red (xlights) -> green (wled)
led 1 green (xlights) -> blue (wled)
led 1 blue (xlights) -> red (wled)
led 1 white (xlights) -> led 1 red (wled)+ led 2 cyan (wled) — ???
This behavior is for each led of universe 1 (up to led 170) also the strange response to white color splitted between led X and X+1.
For led 171 (universe 2) the colors are equal between xlights and wled.

Do you have 510 vs 512 channels per universe? That can cause weirdness like this.xlights needs 510 for wled to work.

I had this same issue with a couple of my controllers. @Thedannymullen is bang on. It was all based on not only the channel count in xLights being off but also the start and end channels and channel counts being off again in FPP outputs setup too. I spent a couple evenings trying to figure the issue out until it finally lined up and suddenly it made sense why it was giving me grief. Had some strips that the one pixel would be blank at times if the settings weren’t right too. Was always the one right after channel 510. Go figure. :rofl:

is it possible to set unviverse size at 480 (160leds) or it fixed at 510?
i have a matrix 40*16 (want to set 4 blocks by 160 leds)