WS2813-E support & not remembering pin assignments

My bug is simply randomly losing some of the pin assignments and altering the led numbers per pin output, also glitching when driving more than one set of WS2813-E as I understand there is a reset timing issue similar to WS2812-C I need to fix this asap, for now, I suppose I will need to reinstall generic Chinese controller to get us by? I can recompile myself although I don know where to adjust the timing?

Please see below

total LEDs 350

output 1

Pin 32

Start 0 count 70

output 2

Pin 33

Start 70 count 130

output 3

Pin 25

Start 130 count 175

output 4

Pin 26

Start 175 count 225

output 5

Pin 27

Start 225 count 280

output 6

Pin 14

Start 280 count 350

after the power cycle the numbers change but not all of the time I have tried 3 different boards now to no avail
mainly the led numbers change for instance

output 5 changes to start 225 and count 225

and 6 start 280 count 70

and sometimes the pin numbers end up being null ie no contents

and occasionally it will lose everything and return to defaults ie pin 2 etc

i have checked flash and cleared it multiple times

Expected behavior
To retain settings

WLED version

  • Board: [ESP32 dev]
  • Version [latest precompiled binary for the esp32]
  • Format [Binary]

Additional context
Please help asap I have rather embarrassed myself making a boat sign for my friend

originally we used an SP608E controller and that had a glitching problem that I solved with 500r resistors just ahead of the first led in a chain. but I wanted to use wled, as soon as I found out you can do 10 channels with esp32 I wanted to change over… I started off by putting a logic level shifter inline bassed on the TX5018E and it glitched like crazy so I tried it right at the letter input without 1.5m of cable and it still glitched, I then bypassed the logic level and went straight to the esp output and it seemed to work for one letter so I went back inside the boat and attached them all bypassing the level shifter and they glitched again, please remember the 500r resistor is still inline would this cause an issue?

Thank you for your help!

You seem to have interpreted “count” as “end”, similar to how segments work. With the LED config, it really is the number of LEDs on that bus. So assuming you wanted output 3 to start at 130 and not have overlapping busses, you’d want output 2 to have a count of 60, not 130. Same for all other busses but the first one.
The counts you are likely looking for are:
70, 60, 45, 50, 55 and 70.
Try this first :slight_smile:

If the glitching issue still doesn’t go away, consider my recommended levelshifter, the SN74AHCT125N, or if you see that only some busses flicker, you could consider daisy chaining them instead of running 6 outputs. Hope you can get it to work nicely!

Thanks for getting back so quickly,

I did originally try that as well to no avail, would this contribute to not remembering pin assignments and messing up the counts? by the way, the first segment seems to like going to 130 and when I set that to 70 it knocks out all of the led settings and defaults to pin2?

and is the timing for reset etc compatible with the generic ws281x option? to reiterate my led is the ws2813e

also would the resistors prior to the first led help or hinder fixing the glitching?

Sounds like your flash is corrupted. Did you follow the flashing procedure in the wiki?

The resistor is to protect the first LED from over-current as well as a bit of impedance matching.

yes multiple boards have been used and i have cleared flash with the python tool

just to additionally confirm this led I’m using is fine and not the problem with timing?