WS2815 problem

Hi, community!
I’m trying to use a 5m WS2815 strip with Nodemcu on ESP8266. The strip has B0 and D0 inputs. I connected the D4 output of the board to the D0 input of the strip through 470Ohm resistor and set the number of the leds to 300 in the WLED led preferences. When I turn the board on, in solid mode the strip flashes with different colors, and generally it’s not controllable at all, although when you change the mode, the lighting pattern changes, but it’s not corresponding to the mode that is mentioned in the UI. If I connect a WS2812 strip, everything works perfectly.
What am I doing wrong?

Try connecting to Data In (DI) instead of Data Out (DO)

DI is input from controller. BI pin on your strip must be connected to GND as per data sheet.

Sorry, my bad. I meant that the controller’s output is connected to DI of the strip. It’s just because the strip is addressable on each led is written DI on the left and DO on the right, and the DI was covered by tape.

I tried this also. Connecting BI to the ground doesn’t change anything.

There’s no way to upload a video here, right?

Can you join WLED discord? It’s more dynamic there.

Do you mean the Discord app?

Problem solved. I just removed the 470Ohm resistance and connected the D4 directly to the DI. But now I have another question. Maybe it’s better to begin a new thread. Regarding the segments. If you create a second segment, for example, shouldn’t it be controlled by the same way that the first? i my setup, it isn’t. Although i set up same colors for both segments, the don’t behave the same.

Read up on them. :wink: