A beginner with QuinLED-ESP32-AB

First, I’m a total beginner at electronics so I hope you don’t mind me asking stupid and you answering with as simple instructions as possible.

I decided to try and start with my first Wled project, got all the parts and have no luck at turning the led strip on, there’s not even a blink. My uneducated guess is that I’m not using the correct pins of the ESP32 board, and I just can’t figure out which pins I should use.

Here’s my setup

  • a QuinLED-ESP32-AB (actually two of them), powered through USB-C, the boards have pins soldered to the inner two rows (the black rows)

  • two led strips (BTF-Lighting WS2812B’s, a 2 meter with 100 leds per meter and a 5 meter with 60 leds per meter, both 5 volts)

  • an old Corsair PC PSU outputting 5 volts (among others), and a another power source which outputs 5 volts and 3 amps

  • a multimeter

  • lots of (short) cables

I’ve flashed the QuinLED’s at install. wled.me and used Wled app on an Android phone to connect to them and update the Wifi-settings, no problem at all. Tried with several different numbers of LED’s to light up from 10-200.

I’ve checked that the led strips are powered, the multimeter shows 5 volts along the strip.

I’ve checked that the arrows on the led strip are pointing away from where it’s powered and the data cable is connected to.

I´ve connected the data cable into QuinLED’s board’s pin IO16 and psu’s ground to QuinLED’s pin GND (the one below IO16), and the psu’s ground is connected to the strip’s ground, too. Btw, does it matter to which ground on the board I connect the ground cable, there seems to be four options? Here’s information of the board’s pinout https://quinled.info/quinled-esp32-board-details/

I’ve tried with both QuinLED board’s and the led strip does not light up, none of the leds. I’ve also tried with both psu’s and both led strips. I can measure 5 volts from the strip.

I’ve booted the QuinLED’s via Wled app. No change. Also reflashed them.

I’m totally clueless after several hours…

Discord may be better place to ask. Also showing a diagram of the wiring. How long and what size of wire are you using on the data line? It doesn’t matter which ground, all grounds should be connected together. You also have to ensure your LED settings in WLED are set to pin 16.

1 Like

Great, thanks! It was the LED settings in the WLED app! The hardware pin was 2 and I changed it into 16 and the lights started working!!!