Ethernet not working on VLANS

I tried search but couldn’t quite find what I was looking for so here it goes.

Background Info:

  • I have a QuinLED dig-Quad with wireless and a QuinLED dig-Quad with QuinLED-ESP32-ABE ethernet shield. Both running WLED 13.3.3 loaded from the web installer (tried ESP flasher tool as well)
  • Home Network: Ubiquiti Dream Machine with separate VLANs (wireless and hardwired) for typical “Home”, “IOT” and “nOT” (not internet of things)
  • I have setup routing rules so my home PC can reach each of the VLANs (confirmed operation by pinging IP’s on each subnet)

my wireless dig-quad will work on any of my three wifi, IOT or nOT networks (i can access it from my phone or PC), my Ethernet dig quad works (i can connect to it), but only on my default Home network. As soon as I change the IP address in WLED to a different subnet I can no longer reach the IP address from my home PC or my android cell phone (i switch to the correct SSID/VLAN when trying). The IP address shows up in the Unifi router table but I cannot ping it.

I tried leaving WLED IP setting to (DHCP) and then in my router set a fixed IP address for the device’s MAC address to my nOT network… but that does not seem to work either. I set the router port to only my nOT network, cycle power on the dig-quad…but nothing, it still seems to hold its original “Home” network IP (proven when i switch the router port back to all VLANs i can then ping it on the home VLAN) It seems that when leaving the device in “DHCP mode” the WLED is not really allowing the router to change its IP address… (i think)

Not sure if my problem is lack of understanding on VLANs, WLED or both… any thoughts, or suggestions would be welcome. I have plans for about 500’ for my house/garage/fence line but I need to have the controllers working solid before i pull the trigger on everything else.

Thank you for your help

its looking like a routing/forwarding thing on my Ubiquiti side on the hardwire network. Just plugged a laptop in and set it to the nOT Vlan… its not getting through either. Ill post an update once i get it sorted/

Well problem is solved. It took much longer than i care to admit but the port vlan setting from my router to my unifi switch was set to only my main vlan and not all of them… Well onto more testing.