How to connect a WT32-ETH01 using ethernet?

Hello everyone,

I flashed the WLED application to my WT32-ETH01 and used the wireless connection to set the ethernet type in the WLED settings to “WT32-ETH01”. Now I like to create a direct wireless connection using ethernet. So the WT32-ETH01 is connected with an ethernet cable to my laptop over a ethernet-usb adapter - but this doesn’t work yet. How can I do this correctly and how can I figure out the IP address, which I need to start the WLED web application?

Thanks in advance!

On the first stage you missed that step. Instead of using wi-fi you have to choose ethernet connection and type of your interface.

Do you mean the step, shown in the picture? Otherwise, how can I do this?

Yes. According to your post you connected to wi-fi. Re-flash your board and start from this step.

But what comes next? There is still the Problem with the IP address. I use the command window to type in “ipconfig” and see the IP4 Address of the controller. But I cant open a connection with this address.

I think you’re confusing some network concepts.
On a PC, opening a cmd window and typing “ipconfig” will show you the network information for your PC
That IP address has nothing to do with your ESP32 board.
You have to configure the ESP32 with a different IP on the same subnet as your PC.

I tried the following:

I reinstalled WLED and set a WLAN connection.

In the WLED settings:

  • changed the Ethernet dropdown to “wt32-eth01”
  • changed the ip address to 192.168.1.2
  • changed the subnet mask to 255.255.255.0
  • changed the gateway to 192.168.1.1

On the laptop settings:

  • as shown in the picture

But the connection over ethernet still don’t work. Do you see more mistakes in my procedure?

Better to use DHCP and reserve address at your router to make it permanent.

How are you cabling things together? Eg;

ethernet cable from laptop (192.168.1.3) to router (192.168.1.1), and
ethernet cable from W32-eth01 (192.168.1.2) to router (192.168.1.1)

Or you could be cabling the laptop directly to the W32-eth01, a different case.

And then on your laptop, in a browser, entering URL: http://192.168.1.2

Update: I found the solution. It seems like the web installer was my problem. A friend of mine told me that sometimes the flushed files from the web installer is a little defective in sense of the ethernet connection. I used files from git to flash the same wled version and it worked.
I created a net with participants using the same subnet mask (192.168.1.1 and 192.168.1.2 are my ips) and it works without router.

1 Like

Hi
Is there anyone who know a way to send artnet over Ethernet to the Eth01? Theres a case where i must wire it. But i’m not able to hack the code…

No different than over Wifi they’re both Ethernet, one uses a cable the other doesn’t.
WLED doesn’t know or care how you sent your requests.

Have you got artnet working over WiFi?

And rather than latching on to all the other WT32-ETH01 threads, start your own message so we can keep things clear as to who were talking to/about.

The process I always use with the WT32-ETH01 is burn the standard WLED (not the ethernet one) and connect to it with WiFi to configure your settings (connect it to your WiFi, set your IP Address, etc.).

From there, you can upgrade your WLED to the Ethernet version and it will keep any IP addressing that you have previously set. Make sure you set the ethernet type to the proper setting (WT32-ETH01) and you can then plug in an ethernet cable between the ETH01 and your switch/router and access it by that IP address.

Yes, it’s an extra step, but I’ve also had issues burning the ethernet version directly to the board and having it work correctly.

Haven’t had a need for that, Ethernet is disabled by default anyway until you go select the ETH01 mode.
You might have run into the unreliable boot issue.

I followed your instructions here but I couldn’t set this up without a router. This was my process:

  1. I installed the standard ESP32 version
  2. changed the WT32 ip address to 192.168.1.2
  3. changed the subnet mask to 255.255.255.0
  4. changed the PC ethernet ip address to 192.168.1.1 and subnet to 255.255.255.0
  5. via AP mode OTA updated to ESP32_ethernet
  6. connected Ethernet cable and rebooted
  7. opened 192.168.1.2 in the browser

Am I missing something?

Did you also set a gateway? From my experience the static IP won’t be used unless you do (even if there’s nothing at the IP you set, just has to be something set).

Unfortunately, this didn’t work as well. I’ve set the gateway to 192.168.1.1 and ip addresses accordingly to .2 and .3 - same subnet. What else can be done?

Standard version is not supporting Ethernet. You have compile your own firmware with proper flag or grab bin file here WLED-wemos-shield/resources/Firmware/@Aircoookie/Latest/WLED_0.14.2_esp32_ethernet.bin at master · srg74/WLED-wemos-shield · GitHub
or latest WLED-wemos-shield/resources/Firmware/@Aircoookie/Dev/WLED_0.15.0-b2_esp32_ethernet.bin at master · srg74/WLED-wemos-shield · GitHub