IR Controller Basic Setup?

I have connected the tsop38238 to the ESP8266 D1 Mini, 5V, GND, and D2 (aka GPIO4).
Then I have enabled the 40-key blue Infrared remote that I have in the Sync Settings of WLED.
So now I want to test it.
The wiki/Infrared-Control says “Firstly, connect your ESP8266 to a PC and open the Arduino IDE serial monitor. Try pressing the button(s) you’d like to program. If your receiver is connected correctly, you should see something like this printed to the serial monitor”
But I nothing’s happening at the serial monitor.
I checked:
In Arduini IDE several settings for the board, e.g. Generic ESP8266 Module, Wemos D1 R1.
The COM Port is ok.
RC sends signals, tested with IRremoteESP8266
What do I need to do to get a response from the RC? What have I missed?

What firmware revision are you using? Did you set the IR PIN in the PIN settings in the WLED UI? Does the d1 mini control your LEDs correctly when using the WLED UI?

I have not done this (yet), but when I do, I will not use the Arduino IDE no matter what the WLED wiki suggests. I will use VS Code with Platform IO IDE because it will save me time - and frustration. I know it will simply work no matter how things are setup. The serial monitor will work as long as I don’t use the default serial port TX/RX pins for something else, like driving LEDs.

Firmware is 0.12
I didn’t set the PIN in the settings because I couldn’t find it. But wiki says “The default sensor pin is GPIO4”. However I would check it, where is the setting hidden? :wink:
Update: found it under LED. So does PIN 4 mean GPIO4? That is set now.
Everything else is fine and working as intended.

I have no clue about Arduino IDE neither Platform IO. I know what it’s good for but I havent used it yet
Except the test with IRremoteESP8266. I just compiled and uploaded it for the test and it worked.
So how is that suggestion from the wiki intended anyway. Does ist suggest to just connect the ESP with WLED onboard to the PC, start Arduino IDE and the check the output on the serial monitor?

I just want to check the functionality of the IR sensor with WLED. But how?
Maybe I should say that I have no LED strip connected at the time.

LED Preferences has the pin assignments.

Seems not to do anything to the WLED

Hook up a short LED strip, or leave the default # of LEDs at 30 and connect up an LED strip.
Then you can try out the IR remote control you are using to see how WLED is interpreting the commands. If it is interpreting them as you want, you are done. If not, there is more than one IR remote option, so select a different built-in IR remote and try again.

No nothing. I have checked a bunch of RC settings, but since mine is blue and has 40 keys I am pretty confident it is the 40-key blue setting.
I get the feedback from IRremoteESP8266, so IR transmitter is working. WLED is also working.
Is there no easy way to check whether WLED receives the IR codes from the remote?
I have Data for LED on GPIO2 and IR out on GPIO4.
WLED LED Preferences: Button and Relay pins are -1, IR PIN is 4.

IR should be connected to 3.3V not 5V

1 Like

Is it the stock WLED build? The Sound Reactive branch has IR disabled by default. Also reboot the board after you set the IR pin.

…like @srg74 said:
Use 3.3V PIN instead of 5V and go to “Config” → “LED Preferences” , scroll down to “Hardware Setup” and enter “4” in field “IR pin”.

Then press “save” and go to “Sync interfaces” and choose something under “Infrared Remote”.

After pressing “save” everything should work fine.

Good luck, Ralf aka Def3nder