New controller SP511E

@Artacus your link to the SP511e bin file is broken on your github. The sound reactive bin file is still there.

Any particular reason why? Perhaps you could load some instructions on how we can tweak and generate our own bin file (supplementing the WLED documentation with the bits to made buttons work etc)

Or if possible upload a new file?

Serg deleted the beta builds after 0.13 was released. You can grab the latest here. WLED-wemos-shield/resources/Firmware/WLED_wemos_shield/v0.13.2-a0 at master · srg74/WLED-wemos-shield · GitHub

And the very first post in this thread has the platform.ini settings you’d need to build it yourself.

All release files are available @Aircoookie repo. I’m trying to compile only the latest code for further testing and debugging by actual users who can’t compile but willing to help with development :slight_smile:

Thanks both! thanks for your detailed posts and github instructions I got this running rather seamlessly. A tip from me - instead of soldering the long pins on your header connections together, I just crossed them over - letting people do it without soldering. Obviosuly be cautious with making sure connections are secure when flashing (I taped them together)

Lastly, could be worth pointing your github instructions to this discussion here because I didn’t realise there were compiling instructions in the first post but do now:)

Thanks for all your work on this, great stuff.

1 Like

Hi, thanks for the guide and for your work. I just wanted to ask does SoundReactive 0.13.0b-3 has alexa enabled? I saw it was disabled on earlier builds but not sure if it is now or not. I switched to standart wled for alexa support and have been using ledfx to music sync but it would be much simpler if i had the option just to use the mic on the board.

The great thing about open source, you can compile yourself with whatever options you want compiled in. But with 2MB, you are already pretty close to not being able to do OTA updates.

Hello.

If I want to stick with stable releases for an SP511E (only 2MB flash), I suppose that I should use WLED_0.x.x_ESP02.bin image from Aircookie releases as per below explanation, is that right?

https://kno.wled.ge/basics/install-binary/#what-binary-should-i-use

Thanks for letting me know.

Yeah, I’ve been out of town, but I’m going to build and publish a stable release when I get back later this week.

You can use fresh one from here WLED-wemos-shield/resources/Firmware/WLED_wemos_shield/v0.13.2-a0 at master · srg74/WLED-wemos-shield · GitHub

Here’s the latest stable release 0.13.1
https://github.com/scottrbailey/WLED-Utils/raw/gh-pages/firmware/WLED_0.13.1_sp511e.bin

Super excited to start loading these controllers with WLED. Any tips on getting the controller open? Appears to be glued on the power connector end and I don’t want to break anything prying it.

I’ve not tried one yet, but I’d bet no glue and you just need a spudger…

Yeah, they weren’t initially glued and came apart easily with a small screwdriver. But the last several batches have been glued and needed pried open with a knife starting near the DC plug.

I occasionally break one of the legs, but the still fit back together.

Hello @Artacus

New 0.13.3 release from official site is ready to update ours SP511E devices?
It appears as compatible device here

Or should we wait to (your ;-)) a new compilation?

Thanks

Just received my SP511E and wondering the same question. Did you try official release directly from web installer ?

I used the bot channel on discord to live compile a current 0.13.3 w/ Discord
used the “./build builtin sp511e” command.

Loaded via OTA, works just fine.

Haven’t tried a straight 8266 build from releases yet, might be OK.

Thanks! I will try that but first I have to figure out how to flash it because it happened that my USB to TTL is with FTDI not with CP2102 like shown in the tutorial. I have tried with it and with Arduino nano with CH340G but no success on both…

I’ve had no trouble with FTDI and those boards.
The biggest issue is making a pin-jig to contact the traces.
You have to make good contact at just the right time.

I had good luck with the web installer.

Tried on different PC and this time worked with FTDI ! I guess drivers issue on first one.
Thanks to the community and devs.

Thanks! I didn’t know about the bot.