Not recognizing ESP8266-12E serial when tryingto reprogram

I have several KeeYees 3pcs ESP8266 NodeMCU CP2102 ESP-12E and have no problems with accessing their serial ports, but when I tried to reprogram one that has WLED 0.80.8…5 (forgot security OTA password), windows does not recognize the usb device. This is not a missing serial driver because the other esp8266 are recognized without problems.

The device manager to the “Unknown USB Device”

General device status “Currently, this hardware device is not connected to the computer. (Code 45)”

Events: Device not started
"Device USB\VID_0000&PID_0002\5&2b41b6c5&0&2 had a problem starting.

Driver Name: usb.inf
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Lower Filters:
Upper Filters:
Problem: 0x2B
Problem Status: 0x0"


Ota default pwd is wledota if I recall the wled wiki post.

If you did not actively change the OTA password, try the default wledota.

Try if Windows recognizes a different ESP. Maybe the USB cable is faulty or not a data cable.
What flashing tool are you using?

Hope you can get it to work :slight_smile:

CP2102 USB/TTL adapter are not very well reconized. The CH340 is working very well. That one works very well. We advise this on also for Tasmota. Here a link to one of the most used adapter:
-> or

First, thanks for the replies, I appreciate the support. Aircookie, I love the new 0.9.1 software segments feature. It works great!

FYI, I am using NodeMCU-PyFlasher-4.0-x64, but that does not matter if I do not see a serial port for it to use (in W10 device manager). I have connected and programmed three other ESP8266-12e chips with WLED successfully (and the serial port shows up without issues), so I do not think it is a device driver or baud rate issue. I’ve update two other ESP8266-12e from 0.8.6 (both wthout OTA passwords).

The problem ESP8266-12e has been running “WLED version 0.8.6” for the last month without problem, and continues to run the software without issues (other than the serial port not showing up).

I have tried the “wledota” password and any other password that I might have used (this was the first one that I programmed and I do believe that I changed the OTA password like is recommended, hum… old age?), without success.

I have some old JTAG serial to USB cables from the old days of using them configure cell phones. Could I bypass the built-in serial to usb chip for an external one? If so, can someone point me in the right direction for details with a ESP8266-12e (second serial port? or by pass console serial port chip?)? I do not have any experience with that yet, but I am not afraid to try it (time to google this topic).

Note that the ESP8266-12e is not that expensive, so I can easily replaced it (well I have already). But I am learning about the ESP’s and programming. I have a need to understand and learn from this issue.

Just thought of a really simple solution I totally forgot!
Just do a factory reset using the checkmark in the bottom of security settings.
It will delete all your presets and config, but also unlock the OTA, so you’ll be able to flash the 0.9.1 binary!

Really glad you like the new version by the way :slight_smile:

It should be possible to connect another USB to serial adapter flasher to the same pins as the built-in one as long as you do not power the board from it’s USB port. Given the price of these, it only really makes sense to do if you want to take it as a learning project :smile: