Slow and sever delay with WLED+ Jinx+ E1.31 OR Artnet OR + NodeMCU ( ESP8266 + chipCP2102 )+ WS2812B matrix

Dear ALL,

I am trying to set scrolling text to my LEDmatrix using WLED. My method is using Jinx to set it in realtime. However, I tried many times and servre delay problems always meet me. Does anyone know why? Please also see my video. Thank you all! WLED forever

Are you too far from your router maybe? I am about 10ft from my router and with a 256 pixel matrix there is no lag using E1.31 from wled to Jinx. Tested on 13 b5 firmware and 13.1 with an 8266. If just changing colors in wled does it do it quickly or is there lag?

(note: I am not the Jinx dev. I picked this name before I knew about the Jinx software. It’s my dog’s name lol)

1 Like

Hello Jinx! Hahah. Nice name. Later call me WLED.
My chip is so colse to the router just less than 1 meter.
My set is totally same as yours but still huge lags.
Did you change the configuarions in the LED sync in WLED?
Is that because I am using WIFI6 router?

Hmm. Nope didn’t change anything in wled. Are you sure you have your matrix configured correct in Jinx?

Output device: select your device and click edit. Under Data: channels 512, chan/block 512, Blocks 1

Matrix Dimension: 8x8, Pixel count 64
Matrix Options: PixelStep: 1, Space between: 1

Sure the output patch is correct? To test and see if you have it drawn correct: Set channel 1 effect 1 to scrolling text. Change the text to something simple like a T and resize it if needed. Slow the scroll speed down. See if that T moves from right to left. If not you need to fix your output patch. It is a little confusing. Not so much with your small matrix but once you get past universe 1 it is or was for me lol.

If all that is correct I am out of ideas, sorry.

Oh you didn’t say if you tried changing the matrix colors from within wled? Try that and if there is lag there as well then the problem has nothing to do with Jinx.

Also, you have all your grounds tied together right? power supply output, esp and matrix?

Dear mate,

thank you so much for replying to me and answer my question. You are the hope for me becuase any others dont want to help me.

I tried all the things and now my guess is correct. It is due to the dammmm router. Motherfucker I used the 802.11b/g/n mixed mode. I just changed it to a single mode such as 802.11b and no more lags. Fuck I wasted 1 month working on this. I am so pissed!!!

Thank you anyway. I love you jinx!

Well that sucks. Glad you found the problem though. For the heck of it maybe try turning off the wifi sleep in the wled config? I don’t have wifi 6. I can tell you that with my wifi 5 router it is set on auto for mode type. Maybe someone else will chime in if they have had that sort of problem. Good Luck :upside_down_face:

Yes I love Jinx too , very cool