WLED SoundReactive controller reset-restart failure

Bought a WLED-controller with IR remote from Aliexpress:

After I set up the controller with one led strip everything was ok. After 5 mins the controller lost the signal of the IR remote, could not operate with remote anymore. Swapped the battery of the IR, same situation. There is a button at the top of the controller, pressing more than 7 sec is resetting the controller, I tought it would solve the problem. When the controller was working well I set up the wifi AP on the controller with no PW.
After I did the reboot I can see only WLED-AP as a new wifi network not the WLED-SoundReactive as it was at the first time. So it seems the controller did not forget some settings and stacked into a loop becasuse I can not connect to the wifi AP he create. Tried the resetting method again, tried the 6times power on-off, was trying power on holding the reset button, nothing solved the problem, the controller did not go back to factory settings. What am I doing wrong or what should I do? Thanks (Sorry for the huge link).

If you held down the button, You reset the controller to the factory defaults. You will need to connect to that WLED-AP and navigate your browser to and go in and reconfigure your wifi and LED settings. You will likely also need to set the correct gpio #'s for the led port, the IR remote and maybe the relay.

From the listing (you may want to save this info):


Yep, that is it, wled1234 the default pw… absolutely one way street i turned into… Now there is only one thing to flash the original fw back on the device.
Thanks for your reply.

If all you did was hold the reset button, the esp still has the same firmware on it. It just reset all the values to WLED defaults. It would still be the SoundReactive version. It just defaulted the Internal Access points name to WLED-AP. If you want it to say WLED-SoundReactive just change WLED-AP to that in the settings.

If you want to upgrade/downgrade the firmware on that board you need to either OTA it or use a USB to TTL Serial adapter wired to the pins in the attached pic.


Thanks, everything works fine now.